ICOM A2 ISTA-D not registered (solved)

Several months ago, I got BMW ICOM A2+B+C emulator from China, and I’ve installed ISTA-D and ISTA-P like this video tutorial shows:
HOW TO INSTALL BMW ISPI NEXT 3.47.10 + ISTAP 54.3.002

Video

http://www.worldobd2.com/wholesale/bmw-icom-a2.html#Video

 

BMW ICOM A2+B+C install Process Question

ISTA-P seems to work(via Loader) but ISTA-D won’t.

If I open ISTA-D I’m getting the message
Code:
Attention – This device has not been registered

If I change the following line from “true” to “false”
Code:
<add key=”BMW.Rheingold.CoreFramework.ILeanActive”
value=”false”/>
I get an other window than the not registered:
Code:
License warning!
Unfortunately your local copy is not activated yet or has expired.
It’s necessary to activate your local installation via an
authenticated license. Please follow the steps in the next dialogs.

If I continue there are fields for Name / E-Mail / Comment, after that it shows an key, which should be sent via mail to them. Below there is an field for a license. I also copied the license from an other and earlier version(3.44.30 which seems to be update only) in this field but still can’t click on the next button which is greyed out.

The ISPI Admin Client shows all installed.
Code:
ISPI Admin Client: 1.1.808.3
ISTA: 3.48.20.13322
ISTA/P: 3.55.0.300
HDD-Update: 2.2.5449.17449
KSD: 2014.12.1.0

After I’ve read it never would activate in a VMware VM I’ve installed it on a physical machine but same problem there.

I don’t know if you need any more information, here are my system information:
Windows 7 x86 in VM, x64 physical, 4GB RAM, 180+ HDD, .NET Framework 4.5, newest Flash / Shockwave (…), “ISTA_SYS_3.48.20.13322.msi”

Solution:
The only thing you need to do is run the “ID.reg” file so it will add some info to the registry. After this, ISTA/D should work fine!

Copy Protected by Chetan's WP-Copyprotect.