Note on 9Upgrade Comand Online 4.5 to latest version 4.7

Question:
I have Merc C200 Dec 2011 registered saloon car. I want to upgrade my
Comand online to latest firmware.
I am able to connect my iphone 5s with Bluetooth to play music and
making calls but I am not able to browse data in Comand online which I believe has been solved in later versions..
My merc shows HU version as 11.23.00 which I believe is NTG4.5.

Could you advise if I can upgrade it to 4.7 or latest versions?

Answer:
4.7 (the one that supports Bluetooth PAN, i.e iPhone) is different hardware to the 4.5. I don’t know exactly what, but i’d suspect the bluetooth chipset is different at least.

So, upgrading your 4.5 to the latest firmware won’t make iPhone work. Not, you can’t upgrade firmware yourself, has to be done with online Xentry which means Mercedes dealer or very specialist independent.

It is possible to replace a Comand 4.5 unit with a Comand 4.7 unit and code everything by hand to make it work, but pretty sure you can’t SCN code it (to get config perfect) because the SCN coding will say that control unit isn’t valid for that car. As the map pin code algorithm is same for NTG4.5 and NTG4.7 it will still be possible for Mercedes to generate the pin codes for new maps.

If your car should have NTG4.5 and you have an Audio-20, and you follow the proper procedures to do a retrofit but try using a 4.7 unit it won’t work as the start-up procedure will know its not meant to have 4.7. This means that the start-up will not update Mercedes database and you will not be able to generate a map pin for the map. This means buying an (expensive) dodgy map pin from some hacker on the internet each time you need to update the maps. So not recommended at all.

Copy Protected by Chetan's WP-Copyprotect.